This project has moved and is read-only. For the latest updates, please go here.

Weird issue responding to tickets

Dec 28, 2009 at 9:52 PM

We've been using Ticketdesk now for several months and things have been working great.  About a month ago something weird has started happening.  I thought it was just me, but it's happening to the other technicians responding to tickets as well (but not all).  When I go to resolve or close a ticket, it requires input.  So I type something in and hit the submit button for my action, it does a quick refresh and says that the reason is required and the text box resets.  If I keep trying to resolve or close, IE eventually crashes and restores the tab.  What's weird is, it will then work.  This is an intermittant issue and I've been unable to determine any pattern to it.  I'm using IE8, but others also have IE7.  Any ideas?  I believe I'm running the latest version of TicketDesk.

Dec 28, 2009 at 10:47 PM

Please try Firefox and you will most likely see the problem go away.. Ticket desk can be incorporated into IE8 however with alot of tweaking. In the long run it just isn't worth it because firefox although not defacto standard is still a better browser. If you found yourself using ticket desk you more than likely found yourself using it because it fits the bill and does it well. Same with Firefox vs IE. (IMO) They both do the job. Just one does it better. ( IMO )
----- Original Message -----
From: [email removed]
To: [email removed]
Sent: Monday, December 28, 2009 4:52 PM
Subject: Weird issue responding to tickets [TicketDesk:79219]

From: mrchen911

We've been using Ticketdesk now for several months and things have been working great. About a month ago something weird has started happening. I thought it was just me, but it's happening to the other technicians responding to tickets as well (but not all). When I go to resolve or close a ticket, it requires input. So I type something in and hit the submit button for my action, it does a quick refresh and says that the reason is required and the text box resets. If I keep trying to resolve or close, IE eventually crashes and restores the tab. What's weird is, it will then work. This is an intermittant issue and I've been unable to determine any pattern to it. I'm using IE8, but others also have IE7. Any ideas? I believe I'm running the latest version of TicketDesk.

Dec 29, 2009 at 12:27 AM

I've seen this issue before, but it isn't common in all environments. Generally there will be an error during one of the ajax postbacks to the server. These aren't visible in the browser, but they leave the page in an inconsistent state. If you check the ELMAH error logs it may be catching these errors though, which can help you narrow down what is going wrong. But not all ajax errors get thrown to ELMAH. Also, there could be javascript errors on the client that cause a similar set of behaviors. These you can catch by telling IE to notify you of all script errors. Either way though, there isn't much help I can give without knowing what specifically is causing the problem in your situation.

For TicketDesk 2.0 I have abandoned the Ajax Control Toolkit, which seems to be the primary source for this kind of problem (among the many other problems I've had with it).